5D Mark II Team

Improvements & Gear

Firmware 2.0.4 Released

Content:

  • Firmware 2.0.4 Released
  • Considerations
  • Support
    .

FIRMWARE 2.0.4 RELEASED

Special Thanks to Canon Firmware Team for this great update and for fixing the previous reported problem very fast.

Download Firmware 2.0.4 from here:

http://web.canon.jp/imaging/eosd/firm-e/eos5dmk2/firmware.html

PLEASE: Follow carefully all instructions to update your camera. Do not touch anything during the process.

CONSIDERATIONS

As we reported in our previous post, we collected few other possible issues that were supposed to be malfunctions of update 2.0.3. But after some deep tests everything seems to work fine.

We will keep checking and reporting on them or any other possible issue. We are welcome to receive any comment regarding issues that users might find.

As we said, this is a really great update, although more professional on video and cinematography should have been given with beta versions to test deeper and detect issues faster, and even make some suggestions.

SUPPORT

If you think all our efforts and campaigns to help to brig these updates for improvements to ALL users since beginning of 2009 (1st for Full Manual Control, later for STANDARD 23.976/25/29.97fps modes) and some further ones deserve some support, please consider supporting us.

You can read a brief history of the whole process here, here, here and here.

The whole story would be very long to tell, and even include some aspects not publicly known, so we won’t bore you.

We will keep watching closely to check if further improvements are possible to achieve. Few of the most requested ones are 720p50/60 mode and Full HD output through HDMI. So stay tuned, this might continue.

No matter the amount, your help will be very much appreciated and valuable.

We really need your support. Thank you very much in advance.

March 19, 2010 Posted by | EOS 5D Mk II, Firmware Updates, News & Info | , , , , , , , , , , , , , , | Leave a comment

Bugs / Issues on Firmware 2.0.3

Content:

  • Bug / Issue
  • Considerations
  • Contact Canon

BUG / ISSUE

The firmware 2.0.3 is in fact a great update and has been very long awaited by thousands of customers, as it was demonstrated by the high overload that Canon servers suffered few hours after it was announced to be available for download.

But a day after its release, there are lot of reports telling an issue related to the new Audio functionality not being registered properly in Custom modes.

Below are few of those reports:

“No audio in C modes unless I set my audio levels in one of the “creative” modes (M, Av, Tv, ) first and then go into my C mode of choice. Kinda defeats the purpose of having a C mode if I have to go to another mode first…”

“I have found the same thing. It only seems to work if you move from one of the other creative modes to a Custom mode. If you turn the camera OFF, then go to a Custom mode, turn the camera back ON, and then try to record Manual audio, you will get signal levels on your meters, but no audio is recorded.”

etc…

CONSIDERATIONS

Probably if video/movie professionals had been given the firmware to test months ago, this bug would have been picked-up and other very easy features could have been suggested for inclusion:

– Option to have histogram overlay whilst actually recording
– Have audio meters showing whilst recording
– Easier/quicker way to change audio levels

We really hope Canon solve it soon. And also add some of the above suggestions too, why not? They are completely possible, just like AutoISO limits.

But the most important now is to fix this problem.

We encourage all customers to report this bug/issue to Canon.

It has to be fixed because custom modes are VERY important and even essential for professionals who use the 5D Mark II on a daily basis.

Just imagine you make all your settings and register them in a Custom mode, like most users and professionals usually do. Then after turning ON the camera you select your Cx mode and start filming, but after you finish your work you notice there is no audio on the footage! It is not normal.

CONTACT CANON

Report this problem. We all need it fixed.

You can Contact Canon by phone or email (we strongly suggest to call Canon if you are in USA or Canada):

– USA: 1-800-828-4040
– CANADA: 1-800-OK-CANON (1-800-652-2666)
– USA e-mail Support

– UK: 0844 369 0100
– Europe e-mail Support
– Europe  Telephone Support

March 17, 2010 Posted by | Articles & Tech Info, Campaigns, CANON, EOS 5D Mk II, Firmware Updates, News & Info, Reports | , , , , , | 8 Comments

   

%d bloggers like this: